IT430 - Information Assurance - Lab 11 - Digital Forensics

Names ________________________, ________________________________

Work in groups of 2 to complete this lab

Goals:


- Understand forensics chain of custody


- Understand forensic techniques:  Image Copying, Data Analysis, Network 
               Traffic Analysis, Registry Analysis
Part I - Chain of Evidence:
· So you are handed a disk and asked to find out as much as you can about the contents of a disk for an investigation about terrorist activities.  You are given a 3.5" drive, but most of the concepts would still hold for a 80Gb drive…copying and analysis would take longer, and you would likely have an entire operating system and file system versus a few files.

· The "Prime Directive" of digital forensics:  never disturb the original evidence! The "Sub-Prime Directive"…make sure you have the legal authority to do a forensics investigation.  Yes, you can be held liable for all sorts of things if you look at someone else's information (and if you are in jail, it will be hard to graduate!)  The next imperative (apparently the Sub-Sub-Prime Directive)….keep an extremely detailed log of every step to include timeframes, what you did (description), how you did it (tools), and what you found (potential evidence).  So the first step after signing for the evidence is to start a log.  Start a log, making it painfully detailed.  Any forensics scientist should be able to repeat your entire process based on the log.  Your log will be worth 5/10 points for this lab…so keep it detailed!  Your log should be repeatable and hopefully have some entries that have notes about why what you collected might be important to your investigation of this evil terrorist.    
· Next, on the sandbox computer open up the Forensics VMImage under c:\IA.  Don't start the image yet.  Note that an exact copy of the physical disk was previously taken, and provided to you as a .img file.  Click on the floppy and add the file TA071123A.img as your floppy.  Start the VM.  Login as student:  PW: GoNavy1!  Now you need to make a copy of the evidence disk.  As you will see later, you want every bit (literally), not just a copy of the files…so you need to use a bit for bit program like dd or the commercial FTK imager.  So we'll try both.  First from the command line make a copy of the a disk where "if" stands for input file and "of" stands for output file.  The format is a little awkward since it was originally written for Unix.  So, from the command prompt go to the c:\Forensics Directory and type dd if=\\.\a: of=yourlastname.img bs=1440k
· But is it the same.  You need to do an md5 hash of the file to verify that you have the original…so you should find that your new img has an md5 hash located in c:\IA\Forensics Lab\TA071123A_FileMD5.txt.  Do this from the command prompt then change directory to c:\forensics  
md5deep yourlastname.img > yourlastname_md5.txt
· Note that md5deep can also do a recursive check of all md5s.  That would come in handy later on…so do a 
md5deep -r > yourlastname_MD5recursive.txt
· By outputting these files to .txt files you have made copying and pasting to your log much easier…Don't forget to keep up your log throughout this entire exercise!
· Now manually checking a lot of MD5s is prone to error and tedious, so let's use the power of the computer to test for you.  Either you can have a file containing "Known Goods" or Known Bads" or you can produce exactly the same output and compare with a program like windiff (or just diff in Linux/Unix).  So, we did these commands on the disk before handing you the copy and got the files…TA071123A_FileMD5.txt (image file) and TA071123A_MD5Deep.txt (recursive).  So compare them with windiff (type in windiff then go to file->compare files).  Then compare them with known goods by doing 
md5deep -wM TA071123A_FileMD5.txt yourlastname_md5.txt

· MD5deep also allows you to check hashes of unknown quantities (with a -x instead of a -w).  When in a forensics investigation would you use this feature recursively on an entire directory?

· Go to www.nsrl.nist.org.  Explain how you can make use of this site (and its databases) to determine if you have malicious software on your system or if your system just has the expected operating system and working files.
Part II - Evidence Gathering

· View the file structure.  What are the visible directories on the disk?

· From that same image, open up the FTK Imager.  The FTK Imager and Forensics Tool Kit are useful tools and run only on Windows systems.  We are using a demo version, but this tool is not free and open source like others we will use later in the lab.
· The FTK imager would allow you to take a dd (with a graphical front end, but we'll assume you can follow a simple set of Windows prompts).  So go to the Forensic Tool Kit, start a case, add the a: drive.  Fill in the investigator and file name then accept all defaults.  Then add evidence, adding the a: drive.  
· Remember the way that disks work.  They keep a file allocation table.  So even if the "perp" deleted files, they are likely listed as marked for deletion in the FAT.  If you are lucky, there may be remaining portions of the files that were not yet overwritten.  Unless someone specifically overwrites sectors on a disk, the information is there, awaiting gathering.  Go into the explore tab.  Notice that you can see graphics of Bombshell Betty Boop even though it has been deleted.  How is this possible (talk about giving you the answer!)?

· Now under the explore tab, go to the work directory.  Note that the FTK knows how to read Microsoft outputs…so you don't have to decipher the code at all.  However what was the signature block in the !WRL2592.tmp file and what potential clues does the information in this temp file give you?

· Go to the search tab…how many occurrences of the word "bomb" were found?  
· Look through the different references for the word bomb.  Note the sources they come from.   A hard disks have 100s of .tmp files.  If given a "suspected terrorist" laptop, what kind of information could you find out from .tmp files (deleted or not) created from Microsoft word, excel and web browsers?

Part III - Boot Disks

· So while, FTK is a good tool for looking at a disk, it requires Windows to operate and more importantly, it writes to the Windows Registry…If you are trying to view a hard drive, you definitely do not want to change the Registry as even the slightest change will place your entire case in doubt.  So most forensic investigators will use a boot disk which takes up memory, but is guaranteed not to touch the operating system.  As you would suspect, any cool tool like this uses…you guessed it Linux or Unix as its operating system.  So you would download a cd image (.iso) from the net and because it is a security tool, you would want to check the MD5 against a known good.  There are two forensic boot disks of note:  Helix (which has just forensics tools on it) and Backtrack (which has forensics tools and a lot of the tools used throughout this class for Red Teaming). 
·  So now shut the VMimage down and add the Helix…iso image (in C:\IA\Forensics Lab) as the CD Image (click connect at start-up), then restart the machine and VERY quickly click in the image an hit the F2 (a couple times).  Change the setup to boot the CD first (the + moves the CD to the top).  Exit and Save.  Choose the GUI.  Wait about 2 minutes for it to boot. 

· Open a terminal as root.  Remember that in Unix, you have to mount a drive to the file system to use it.  Type 
mount -r -t vfat /dev/fd0 /media/floppy0  Now 
cd /media/floppy0 and see that you can navigate the file system as before.  Now type  mount -r /media/hda1, then notice you can navigate that as well.  

· Do a cd /media/hda1/windows/system32/config and list the files.  Which file might you want to grab a copy of and why (Yes, you actually have to retain information from previous labs!)?

· Go ahead and make a directory called evidence in ramdisk with mkdir /ramdisk/evidence.  Copy sam and system files to that directory.  Note that we don't want to write to either hard drive or the floppy as both are potential evidence.  Knowing that Helix does not allow you to write to these disks…so what to do.?  You could either save to a USB drive or you could go via network.  For USB, you would insert the USB, verify that it is there with lsusb, then mkdir /media/usb, and mount it read/write with mount -t vfat /dev/sda1 /dev/media/usb.  We will, however use a network connection for this task.  So, right click on the desktop.  Go to Helix Tools->Services and note that you can start your own SSH server or samba server.  Set the password to GoNavy1!  Set your IP address with 
ifconfig eth0 10.10.10.40.  
· Now open a Green or Black XP (set the IP to 10.10.10.20) , verify that you have a good connection and use program like winscp…all nice and graphical (take from the host desktop) to move both files from ramdisk to your Windows program.  Note that you set the ssh user to knoppix.  So login as knoppix with password GoNavy1!  Open the SAM inside from the Black or Green XP.  Do a 
File->Import from SAM and System Registry Files.  What are the users of the hard drive in question? (Obviously you could crack their passwords at this point)
· So now you have shown that you can see all of the files.  Now we want to show some of the capabilities of a totally free program called Autopsy.  Let's go back to the Helix disk, which if you did it correctly still has the a: drive file attached to the computer.  Check this by cd /media/floppy0 and ensure that you have the three directories on that disk.   Don't forget you should still be listing things in your log.
· Right click on the desktop and go to Forensics->Autopsy (wait about a minute for a web page to come up).  Open a new case, add a host, put in pertinent logging information and then add an image.  The path of the image should be /dev/fd0, ensure you select partition instead of disk.  Change the mount point to a:  Now analyze the file.  If you did it correctly, you should have yellow (not grayed out) File Analysis, Key Word, File Type, Image Details, Meta Data and Data Unit Buttons.  
· If you go into File Analysis, you will notice that you can see the deleted files and directories in Red.  Click on the work link and you will see the deleted .tmp file you found in the more expensive FTK product plus you will see 3 additional deleted files…proving that you don't always get what you pay for.  Click on the temp file link above the Effective Presentation.ppt and note that even though it was created in word, you can still read it very well. 
· Go to Key word search and search for the word bomb (Don't read this out loud at the airport).  Looking at the ASCII of some of these, you get a pretty good idea what this evil terrorist was up to (useful for your log).  
· Now look for delooze  Click into the ASCII.  Clearly Professor Delooze is not a terrorist (or even a "person of interest"), but name two ways that her name would be all over these documents if she didn't create these documents (read the entire ASCII line)?  How could this be potentially valuable in your investigation?
· Now go to the Sort by file-type button.  Go ahead and sort.  Where does it place the data…very important if you want to find it later.

· The Image Details, Meta Data and Data Units allow you to check out the Hex and ASCII sector by sector….this takes a lot of patience and a lot of time.  Try some sector number like 1, 1000 etc. to see how to use these functions.
Part IV - Using the Slack Space (Many of you are already experts at "slacking"!)
· For this task you will click on the Helix desktop and go to Forensics->Hex Editor.  Open the /media/floppy0/work/Project Help.doc
· Scroll down the right window to see the ASCII Text.  Now scroll the right window all the way to the bottom.  Starting at the 4th line from the bottom, overwrite the dots with your hacker names and the number of days until graduation.  Then do a File->Save as /ramdisk/evidence/Project Help.doc
· Move the file over to the windows box, then to the host desk top.  Open the file with Word and note that your message is not shown. (You just did something with the Floppy Evidence, so that should be in your log)

· So while secret messages could be sent in the slack space, the primary concern is that slack space may contain residual information.  This is a huge deal when copying files from the SIPRNET to the NIPRNET.  Based on what you learned today, describe a valid process (more than 2 steps!) that you would need to do to move a document from the SIPRNET to the NIPRNET with assurances that you have not left any classified information in the slack space or deleted directories.
Part V - Windows Registry Analysis

· Since the Windows Registry contains all of the information that runs programs, allows applications and ensures security, as part of your analysis you would definitely want to look at the registry and compare it with known good registries.  You would normally port a number of files in the windows/system32/config directory and look at them with a registry viewer.  In the interest of time, go to your VM XP image (Black or Green).  From the command prompt type regedit.  Click on the HKEY_CURRENT_CONFIG.  Then File->Export save it to the desktop as current_config.  Go to your desktop, right click on the icon and edit it.  

· You will notice that it produces a text file which can be searched, compared etc.  From above you would notice that the NIST site had a number of "known" configurations for windows registries.  How would you use this information to validate if the image may contain root kits which hide certain types of data and processes against the casual observer?
· So, when the Captain says, "I just worked on a project for the past 3 weeks and the computer just ate it", you can try to run some of these tools and at least get some of his or her work back…you could be the next "Hero"…your ability…uncovering the invisible!

· OK, enough torture for one day…Hand in this completed sheet and yes, email your forensics log to your instructor.  Ensure both of your names are on the electronic log.

· Congratulations, you have completed the lab!  Now you are ready to take on the evil hackers of the cyber-world.

Page 6 of 6

