IT430 Lab 7 - Applications Security

Names. ____________________, ___________________________

Work in groups of two to complete this lab

Part Ia

Stack Familiarization

· Describe the two methods that every stack must implement.
· Describe another method that most stacks implement.
· Open the Black-XP VMImage and take a snapshot.  Then start the VMImage.  Login as student, PW:  GoNavy1!

· Open the SecFN (Security for Neophites, Written by ENS Mischler '07).

· Push your first name, last name, alpha, and company onto the stack in that order.

· If your first or last name is longer than 8 characters, the stack will push the name onto more than one line.  Draw the stack below.

· Pop the top two elements from the stack.

· Click the PEEK button.

· What is returned to the peek field?

· What does the peek function do?

· Push your favorite baseball team’s or favorite Muppet's name onto the stack.

· Draw the stack.

Part Ib

Buffer Overflow Exploitation

· Give a description of a buffer overflow (in your own words) and how this can be exploited by bad guys

· Hit the Clear button to clear the stack.

· Select 32 from the Buffer Character Size combo box.
· Enter a string into the bottom text field that consists of less than 32 characters into the "Text for Buffer Input" text box and click the PUSH button (whitespace counts).

· What are the contents of the Stack Frame PTR and Return Address Fields?

· Clear the stack and repeat the above step with more than 32 characters.

· What changed between the two instances?  Make special note of the Stack Frame PTR and Return Address Fields.

· Select File→Clear All
OK, so you are an evil hacker wanting to get into a system for fun and profit.  You have reverse engineered the code and are now reading it in assembly (we'll assume you have a vast knowledge of various assembly languages since you are no script kiddie!).  Your job is to inject the buffer with a payload that will cause your code to be implemented.  In order to accomplish this, you must fill the Return Address with an address that points back to the beginning of your code.  But rarely do we know exactly where the Return Address lies, but we know within a general range.  So at this point we use no-ops which as the name implies is a no-operation (null statement).
· Select Tools→Create custom buffer inject

· Choose a command to inject.

· Enter a number (~4-5) of No-Ops desired and something in the text box to understand how the tool works.
· Click the Inject button.

· Look at the text it created.  Make sure that you have selected a Buffer Character Size that ensures an overflow will occur.

· Click the PUSH button.

· Clear the stack and now add "This is a test" to the text for buffer input.  That may help determine how many no-ops you need.

· Write the contents of a successful exploit.
· Give a short explanation of what would happen if the computer ran the program by popping items off the stack.

· Select Options→Enable Automatic Garbage Collection
· Clear the stack.

· Click on the PUSH button.

· What changed?  Make special note of the Stack Frame PTR and Return Address Fields.

· Clear the text input box, and enter something more than 32 characters.

· Leave the Buffer Character Size at 32.

· Clear the stack.

· Click on the PUSH button.

· Why will a buffer overflow exploit no longer work?

· Explain why automatic garbage collection in Java makes it less susceptible to buffer overflows than C++

· Why if Java is more secure than C++, C or C# would the Department of Defense not simply require that all applications used by DoD be written in Java?

· Now to show you the importance of the buffer overflow in terms of  potentially exploitable vulnerabilities go to http://cve.mitre.org/cve/ Under the National Vulnerability Database, CVE Search, Look for Microsoft XP Professional.  

· Of the 143 vulnerabilities, how many are caused by some sort of buffer of heap overflow (From the browser, search for the word overflow on each page of results, count only once per vulnerability)

· Close out of the SecFN application.

Part IIa

MySQL Familiarization:

Commands in MySQL are terminated by a semi-colon.  Therefore, you can make your commands more readable by entering them on multiple lines and just using the semi-colon at the end of the last line.  This is especially useful for create databases or adding new information.  MySQL commands are not case-sensitive.  They are in all capitalized letters here to distinguish them.

From Black-XP, login to MySQL
· Go to Start->WampServer->Start WampServer (This starts a Windows, Apache, MySQL and PHP application set)

· Open a command prompt and navigate to C:\wamp\mysql\bin.

· Login: mysql –u root
Create a user and login with the new user

· Create a user that has access to the database on the local machine with:

· GRANT ALL PRIVILEGES ON *.* TO ‘student’@’localhost’ IDENTIFIED BY ‘GoNavy1!’ WITH GRANT OPTION;

· When you are using GRANT ALL PRIVILEGES, what specific privileges are being granted?  (hint: http://www-css.fnal.gov/dsg/external/freeware/mysqlAdmin.html)
· Exit MySQL, and login with the user that you just created:

· Type: EXIT
· Type: mysql –p –u student
Create a database

· CREATE DATABASE injectlab;

· Make sure that your database was created successfully: SHOW DATABASES;
· What other databases are present?

· Start using the database: USE injectlab;
Create a table (can be entered on separate lines as shown below, or all on one line)

· CREATE TABLE injectable

· (

· itemNumber
tinyint AUTO_INCREMENT,

· itemName
text,

· itemPrice
decimal(5,2),

· PRIMARY KEY (itemNumber)

· );

View your table

· SHOW TABLES;

· DESCRIBE injectable;

Add an entry

· INSERT INTO injectable (itemName,itemPrice) VALUES (‘iPod’,349.99);

· INSERT INTO injectable (itemName,itemPrice) VALUES (‘iPod’,79.99);

· INSERT INTO injectable (itemName,itemPrice) VALUES (‘Garmin’,699.99);

Make sure that all of the entries were made

· SELECT * FROM injectable;

· Get the prices for all iPods

· SELECT itemPrice FROM injectable WHERE itemName=’iPod’;
· What would the select statement look like if you only wanted to see the itemNumber for the Garmin?
Part IIb

SQL Injection:

SQL Injection attacks depend on the web application sending user provided input directly to the database.  The attacks attempt to change the intention of SQL statements by modifying the existing statement or chaining new statements on.

· Copy the contents of (Black-XP) c:\wamp\www\sqlDatabaseInjectionCreation.txt to the mysql command prompt.

· Keep the MySQL window open so that you can validate your changes.

· Open up http://localhost:8080/IAPage.php in a browser window.

· Enter 88888888 (8 eights) into the member id field.  This brings you to the store front where you can select an item, or search via its item number.  The item number is correlates to the order in which an item was added to the selection.  

· Select any item and click Purchase.

· What does the page display?

· Now that you know how the website is supposed to act, go back to the login page and try to enter as a different customer.

· Try entering 42 into the member id field (why?  Because as you no doubt remember from a previous lab, 42 is the answer to "Life, the Universe and Everything".)

· Now try entering 42 or 1=1 into the member id field.

· Who does the website think you are?

· Why did use the or 1=1 statement?

· Go to the MySQL window and enter the following: SELECT * FROM customer_sensitive;
· Why did the website display that particular name?

· A common injection trick is to make the database perform multiple queries (get more than one record at a time).  However, this only works in MySQL if the programming is using the “mysqli_multi_query” function.  The people at MySQL did not do this for security reasons, but you can still get a lot of information one record at a time….you just have to have patience and record every little bit of information, until you can aggregate the information.
· What foundational security principle is violated when programmers secure the login page against SQL injection or cross-site scripting but do neglect the security of other pages within the site?

· A good place to look for potential inject locations is in search fields.  Enter 1 in the search field and click on Purchase.

· What does the page display?

· Evaluate the error message that was produced on the webpage depicted in c:\wamp\www\fieldNameExample.bmp.

· What are probable field names for the table that is being accessed, and what is the name of the file that holds logic for accessing the database?

· Let’s assume that you have 'reconned' the site, and through error messages, found out the names of the customer table and its fields.  Using this information, go back and modify your search to read: 

· 1; INSERT INTO customer_sensitive VALUES (123,0x4861783072,0x4576696C,0x796573)
· If you entered it in correctly, you should get the same page as when you just entered the 1.  

· Go to the login page and enter 123.

· Who does the website think you are and what privileges do you have?

· So let's break this down.  It turns out mysql won't allow special characters like " / ' etc. in the field but it will except hex values which you can get by doing the following:

· Go to the mysql prompt and type (and notice results)

· SELECT HEX('Hax0r');

· SELECT HEX('Evil');

· SELECT HEX(''yes');
· Go to the mysql prompt and type USE sqlinject;

· SHOW TABLES; then Describe [tablename]; leaving out the []'s
· Explain in your own words what you have done and why you have additional privileges. 
Part IIc

Securing Against SQL Injection Attacks

Never trust user provided input.  Even if the user is innocent, a hacker could be using their browser to leverage an attack.  The best way to protect your web application is by verifying user data.

· Keep your web browser open for this next section.

· In order to secure the page, we are going to make some modifications to the source code. 

· Using Dev-PHP: file→open and navigate to C:\wamp\www\IAPage.php
· Repeat the above step to open securityFunctions.php and CheckOut.php
· First, secure the login page to only accept numbers. 

· At the top of IAPage.php, where it says $use_secure = false; change the false to true. 

· This sends the input member id to the validPosInt( ) function.  The function is located in securityFunctions.php.

· Next, secure the store front.  The code that performs the MySQL query on the search field is located in CheckOut.php.

· At the top of CheckOut.php, change false to true on the following:

· $use_secure = false;

· $use_sql_scrubbing = false;

· $use_strip_tags = false;
· At the moment, $use_sql_scrubbing only protects against the SELECT and DROP commands.  

· Expand upon this by modifying the sqlEncodeWord( ) function found in securityFunctions.php.

· Add case statements for other SQL command words.  Hint: refer to the first question in Part IIa.

· List all SQL command words that you added to the code

· Save all of the changes that you made.

· In your web browser, refresh IAPage.php and return to the login screen.

· Attempt the or 1=1 attack again.

· Login with 88888888 and enter the following in the search field:

· 1; INSERT INTO customer_sensitive VALUES (77303074,0x6861783072,0x3331333337,0x796573)
· Explain in detail how each of the how these built in PhP functions can help secure your site.

· The changes that you made should keep out the script-kiddie that doesn’t know what he’s doing.  However, they will only slow down a determined attacker.  Name a few other changes that will make the web application more secure (be specific).
Part III
Cross-Site Scripting (XSS):

· What are the three types of XSS?  Hint: http://en.wikipedia.org/wiki/Cross-site_scripting
· We are going to focus on stored XSS attacks, because we have a database at our disposal.  Anytime user entered information is displayed, we are susceptible.  

· Open up http://localhost:8080/IAPage.php in a browser window.

· Enter 88888888 (8 eights) into the member id field.

· What displayed information is most likely provided by the user?

· Go back to the login page and enter 1729, which is not a valid user.

· This will ask you to create a new user, and provide us with an opportunity to run a XSS exploit.

· In the member id field, enter: 8675309
· In the first name field, enter: Jenny PWNED
· In the last name field, enter: <script>alert(document.cookie)</script>
· Click on Add User
· Go back to the login page and enter 8675309
· What does the pop-up field say?

· Notice that we were able to continue browsing after the script finished executing.

· It is pretty common to keep someone's connection credentials in a cookie .  You could have them send these cookie results in a datastream, allowing you to perform a man-in-the middle type attack (even on a "secure" connection) 

· Now, we are going to run an exploit off of another user.

· Assume that we obtained another users member id through social engineering.

· Go to the login page and enter 19690703
· What are the users first and last names?

· Go back to the login page and enter 42 to bring us to the new user page.

· Noting that it is pretty common to mistype/transpose numbers in a member ID,  you could add a legitimate user (through normal add screens, that calls a script when it is accidentally typed in).  

· In the member id field, enter: 19960703
· In the first name field, enter: Brian Jones
· In the last name field, enter: <script>function delayRedirect(){window.location="stealingYourInformation.php"}</script><body onLoad="setTimeout('delayRedirect()',3000)">
· Go back to the login page and enter 19960703
· What did the script do?

· Using Dev-PHP: file→open and navigate to C:\wamp\www\securityFunctions.php
· What function(s) could be used to mitigate the threat of XSS attacks?

· Define the difference between SQL injections and Cross-site Scripting (based on what you learned in this lab or "read" from the book.

· Define 5 ways that you can secure the code for your Capstone Project.  Note this is not 5 ways "someone" could secure the code, we are asking what you can do.

IMPORTANT:  First close out of the image, then Revert to the image, then and only then remove your image.  If you do not finish within the lab period you should go through the procedures to make a snapshot when you return, starting from scratch.  To start again at parts IIb, IIc or III, you will need to go through the items in IIIa (page 4) and copy the file from IIb.
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